Scheduled Tasks Not Working

Viewing 15 posts - 1 through 15 (of 26 total)
  • Author
    Posts
  • #2059
    Ted BTed
    Participant

    Hi – My scheduled tasks are not bringing in new content. All of the tasks ran successfully when initially configured, but nothing happens when they try to run as scheduled and nothing content appears when “Show last log” is clicked. Our memory limit is set to 512MB and cron jobs are enabled.

    Please let me know how to fix this issue and thanks for the help!

    #2063
    Suman M.Suman M.
    Keymaster

    Hi, thanks for contacting us. This is a known issue and we are already working on it. Please kindly wait few more days and we’ll be releasing the updated version. Till then you can use manual run. Thanks for your understanding. Have a good weekend!

    #2078
    Ted BTed
    Participant

    Hi Suman – Thanks for the information! Do you know what day the updated version will be available?

    #2079
    Suman M.Suman M.
    Keymaster

    Hi, it shall be available next week. I hope you can use manual run till then. Thanks for your understanding!

    #2092
    Suman M.Suman M.
    Keymaster

    Hi, Scraper version 2.0.1 is released. You can download it from your Envato Panel. Can you please update and check the scheduled task?

    Thanks & Regards!

    #2098
    Ted BTed
    Participant

    Hi Suman – We updated to version 2.0.1 and this still doesn’t seem to be working for most of our scheduled tasks. They are scheduled to run every three hours but no log is showing and they are displaying several days ago for “Last Run” and “Last Complete”, as well as “- seconds” for “Last Process Duration”. All of the tasks experiencing this issue say “In Queue” rather than a time they will run again.

    Any suggestions on how we can fix this? Thanks for the help!

    #2105
    Suman M.Suman M.
    Keymaster

    Hi, can you please let us know your site’s wp-admin login details (as private reply) so that we can check the issue further. Also, for now please do not schedule more than 2 tasks.

    • This reply was modified 2 years, 6 months ago by Suman M.Suman M..
    #2107
    Suman M.Suman M.
    Keymaster

    Also, I’m posting your another ticket here itself so that it’s easier to track everything in one ticket.

    ———————————————-

    Hello – I’m trying to fetch all posts that are linked to from this URL: https://www.sfc.hk/edistributionWeb/gateway/EN/news-and-announcements/news/. When I go to Post Items, I can select the Item Path for each post and see all items listed under the Sample dropdown. I can also select the content I want in the Post Content area. However, when I click Scrape to generate a preview, only a single post is shown, rather than all posts. Also, only a single post comes in when I run the task.

    Please let me know how I can fetch all posts. Thanks for the help!

    #2109
    Suman M.Suman M.
    Keymaster

    We’ll also check the multipost scraping issue related to https://www.sfc.hk/edistributionWeb/gateway/EN/news-and-announcements/news/ when you send us the login details.
    Thanks!

    #2111
    Ted BTed
    Participant
    This reply has been marked as private.
    #2119
    Suman M.Suman M.
    Keymaster

    I have updated post_content XPath for the task “New Zealand – FMA – News”. It’s working now.

    Regarding the task “Hong Kong – SFC – All News”, I’m not being able to fetch the multiple posts even using manual XPaths. I’ll need to check this further.

    I have schedules to run task “Netherlands – AFM – News (Professionals)” every 30 minutes and paused other tasks so as to check if scheduling is working fine or not in your site.

    Thanks & Regards!

    #2120
    Suman M.Suman M.
    Keymaster

    UPDATE: I can now scrape from https://www.sfc.hk/edistributionWeb/gateway/EN/news-and-announcements/news/
    Please check the task “Hong Kong – SFC – All News” – https://www.screencast.com/t/X3lHOf26jbb3

    • This reply was modified 2 years, 6 months ago by Suman M.Suman M..
    #2123
    Ted BTed
    Participant
    This reply has been marked as private.
    #2138
    Suman M.Suman M.
    Keymaster

    For “Hong Kong – SFC – All News” task, I’ve set Part field to HTML Source Code for post_content field. Can you please check now?

    #2140
    Ted BTed
    Participant

    Thanks for the help, but it’s still not showing up correctly with the list items in the Preview Results for post_content. I tried to reset the task and see if the posts would import correctly, but the log shows “Already processed post” despite the reset so I can’t tell what happens on import.

    Separately, is there an update regarding why scheduled tasks are not running?

Viewing 15 posts - 1 through 15 (of 26 total)

You must be logged in and have valid license to reply to this topic.

License required for the following item
Login and Registration Log in · Register